wiki:VmwareESXToCiscoGEC

Version 1 (modified by iva, 14 years ago) (diff)

--

Connect ESX Host To Cisco Switch With Gigabit EtherChannel

The vSwitch0 virtual switch was created during installation of ESX software on the host. Service concole port (vswif0) and the "VM Network" port group are both connected to this switch. In vSphere Client (Configuration > Networking) default setup will be depicted like this:

The same information can be displayed from the command line on ESX host as well.

# esxcfg-vswitch -l
Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
vSwitch0         128         3           128               1500    vmnic0

  PortGroup Name        VLAN ID  Used Ports  Uplinks
  VM Network            0        0           vmnic0
  Service Console       0        1           vmnic0

#

First will add a VMkernel port group and configure its IP settings (required for VMotion).

# esxcfg-vswitch -A VMKernel vSwitch0
# esxcfg-vmknic -a -i 10.10.10.20 -n 255.255.255.0 VMKernel

Then will link three additional physical network adapters to the same virtual switch.

# esxcfg-vswitch -L vmnic1 vSwitch0
# esxcfg-vswitch -L vmnic6 vSwitch0
# esxcfg-vswitch -L vmnic7 vSwitch0
#
# esxcfg-vswitch -l
Switch Name      Num Ports   Used Ports  Configured Ports  MTU     Uplinks
vSwitch0         128         7           128               1500    vmnic0,vmnic1,vmnic6,vmnic7

  PortGroup Name        VLAN ID  Used Ports  Uplinks
  VM Network            0        0           vmnic0,vmnic1,vmnic6,vmnic7
  VMKernel              0        1           vmnic0,vmnic1,vmnic6,vmnic7
  Service Console       0        1           vmnic0,vmnic1,vmnic6,vmnic7

#

To configure NIC Teaming will use the vSphere Client.

In vSwitch0 Properties open the NIC Teaming tab, and choose the "Route based on IP hash" option for Load Balancing, and also choose "No" for Fallback. On the General tab one can adjust number of ports supported by the virtual switch. In the latter case reboot will be required for this new setting to take effect.

On a Cisco C2960 switch configure static (without PAgP or LACP) four-port 802.3ad channel group (interfaces Gi0/13 thru Gi0/16 are all configured identically).

port-channel load-balance src-dst-ip
!
interface Port-channel1
 switchport access vlan 301
 switchport mode access
 spanning-tree portfast
!
interface GigabitEthernet0/13
 switchport access vlan 301
 switchport mode access
 no cdp enable
 channel-group 1 mode on
 spanning-tree portfast
!

See Also:

http://www.vmware.com/resources/techresources/997
VMware Virtual Networking Concepts (VMware Technical Papers)

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_52_se/configuration/guide/swethchl.html
Configuring EtherChannels and Link-State Tracking (Catalyst 2960 Switch Software Configuration Guide)

http://en.wikipedia.org/wiki/Link_aggregation
Link aggregation (Wikipedia)

Attachments (4)

Download all attachments as: .zip